Microsoft SharePoint Remote Code Execution Vulnerability (CVE-2019-0604)

April 9, 2019

Summary

A remote code execution vulnerability exists in Microsoft SharePoint when the software fails to check the source markup of an application package. An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the SharePoint application pool and the SharePoint server farm account.

Exploitation of this vulnerability requires that a user uploads a specially crafted SharePoint application package to an affected version of SharePoint.

The security update addresses the vulnerability by correcting how SharePoint checks the source markup of application packages. [1]

Impact

Remote Code Execution

Vulnerable

  • Microsoft SharePoint Server 2019.
  • Microsoft SharePoint Enterprise Server 2016
  • Microsoft SharePoint Foundation 2013 Service Pack 1
  • Microsoft SharePoint Server 2010 Service Pack 2

Recommendations

Microsoft recommends that customers running these versions of SharePoint Server install the updates to be protected from this vulnerability.

To comprehensively address CVE-2019-0604 Microsoft is releasing the following security updates:

  • 4462199 for Microsoft SharePoint Server 2019,
  • 4462211 for Microsoft SharePoint Enterprise Server 2016,
  • 4462202 for Microsoft SharePoint Foundation 2013 Service Pack 1, and
  • 4462184 for Microsoft SharePoint Server 2010 Service Pack 2.

References